Modern Design Library

Description

Note: The plugin has been adopted and is under development. A lighter version is now available and more releases will be pushed in the near future. Stay tuned and report bugs or code inconsistencies.

*Note:** A new version is coming with fully compatible editor blocks, design patterns, a reusable block library and a UI kit.

A Modern Design Library toolkit for creating separators, lines, dividers, decorative elements and more.

The library currently includes a colored line block.

Read more on getButterfly.

Installation

  1. Upload to your plugins folder, usually wp-content/plugins/
  2. Activate the plugin on the plugins screen.
  3. Configure the plugin from Settings -> Modern Design Library.

Reviews

3 Սեպտեմբերի, 2016
Exactly what i needed and was looking since long time,i am very happy 🙂 , thanks alot to the developer, one think if u could help me that will be great. That is "how to set (decrese actually) MDL card size when having separte image placement ". Even if image size is decreased the height remains the same. please tell me Hiw can i achieve that in custom CSS 🙂 thanks
Read all 1 review

Contributors & Developers

“Modern Design Library” is open source software. The following people have contributed to this plugin.

Contributors

Changelog

1.1.0

  • UPDATE: (BREAKING) Added the first block (horizontal/vertical colored line/divider)
  • UPDATE: (BREAKING) Removed old/obsolete libraries
  • UPDATE: Updated WordPress compatibility
  • UPDATE: Updated required PHP version

1.0.6

  • UPDATE: (BREAKING) Removed third-party (external) Material Design stylesheets

1.0.5

  • UPDATE: Updated WordPress compatibility
  • UPDATE: Updated required PHP version

1.0.4

  • UPDATE: Updated plugin tags
  • UPDATE: Updated changelog
  • UPDATE: Updated readme.txt (in progress)
  • UPDATE: Removed demo page
  • UPDATE: Removed plugin settings page (based on Customizer)
  • UPDATE: Refactoring of several classes
  • UPDATE: Removed TGM Plugin Activation dependency
  • UPDATE: Removed Shortcake UI dependency (no shortcode builder available)
  • UPDATE: Prepared plugin for next big release with user options, help, documentation and shortcode builder
  • UPDATE: Updated WordPress compatibility
  • UPDATE: Updated required PHP version
  • UPDATE: Removed included language file and prepared the plugin for native internationalisation (i18n)

1.0.3

  • Move TGM Plugin Activation file to ‘inc’ directory to avoid it showing up as a separate plugin in site’s list of plugins

1.0.2

  • Updated to load MDL Version 1.0.6

1.0.1

  • Updated to load MDL Version 1.0.5 instead of 1.0.4

1.0

  • Initially uploaded to WordPress.org on September 14, 2015